Troubleshooting
  • 29 Jan 2024
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Troubleshooting

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Article summary

Issue 1

An unexpected error has occurred on a receipt. The client and server cannot communicate, because they do not possess a common algorithm.

Detail Issue Analysis

This issue occurs when the client or server does not have a common algorithm to continue the TLS connection. Also, due to either of the following reasons:

  • The client or server might not have the latest patch or algorithm that is not supported on a specific operating system.

<or>

  • The TLS settings are disabled in the registry on the client or the server machine. 

Root Cause

Scenario 1: If a call is made from the browser.

Result: The handshake from the browser may pass.

Scenario 2: If a call is made using some program or application

Result: The handshake from the application may fail.

Solution 

Check the algorithms that are enabled on the client and server operating systems. Enable security algorithms which are common to client and server operating systems. Some applications can be used which give the idea if the client or the server has different versions of the protocols or ciphers enabled.




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